📚 [Jekyll] Jekyll Serve 가 되지 않을 때

Category: Jekyll | 📅 August 20, 2021

잘되던 jekyll s 명령어가 갑자기 안될때가 있다!

에러메시지 왕창 뱉으면서 bundle exec 를 함께 쓰라는…

원인

Gemfile.lock 파일에 등록된 gem 패키지 버전과 실제 실행되는 패키지 버전이 맞지 않아서 발생함 마구 업데이트 한 죄가 크다! ㅠㅠ

해결 1.

$bundle update

해결 2.

Gemfile.lock 파일을 열어서 해당하는 패키지의 버전을 적어준다.

(완전 비추 !! )

💭 Reviews
  • github, gitlab 에서 운영하는 경우, 패키지 미지원으로 충돌 날 수도 있....